ExtService. Запуск Pocket Outlook из приложения для отправки электронной почты

Для интерактивной отправки письма из 1С: Предприятие 8. Расширение для мобильных компьютеров (далее просто 1С) необходимо запустить файл Windowstmail.exe и передать ему ряд параметров.

В программе 1С, начиная  с версии 8.1.4.4, существует базовый метод «ЗапуститьПриложение»:

Синтаксис:

ЗапуститьПриложение(<Строка команды>, <Текущий каталог>, <Дождаться завершения>)

 

где в строке команды можно также передавать и параметры. На более ранней версии программы 1С можно воспользоваться соответствующим методом внешней компоненты «ExtService», см. пример ниже.


Базовый метод, пример 1:

 

Процедура ОтправитьПочтуШтатно()

    ИмяПриложения   =“windowstmail.exe”;

    Аргументы       =“mailto:test@test.ru?subject=Проверка отправки почты&body=текст письма:проверка отправки почты”;

    СтрокаКоманды = ИмяПриложения +” “+Аргументы;

    ЗапуститьПриложение(СтрокаКоманды,“windows”,Ложь);

КонецПроцедуры

В результате выполнения данной процедуры будет открыта программа Pocket Outlook и создано новое письмо, пользователю остается только отправить его, нажав на кнопку «Send»:

PocketOutlook1

Есть и другой вариант передачи параметров:

-to “<e-mail>” адрес отправителя
-сс “<e-mail>” копия
-bcc “<e-mail>” скрытая копия
-subject “<subject>” тема сообщения
-body “<body>” текст сообщения
-attach “<file name>” файл вложения
-service “<account name>” Имя учетной записи с помощью которой будет создано сообщение. В случае если service не указан и существует более одной учетной записи, пользователю будет предложено выбрать учетную запись.

Базовый метод, пример 2. Отправка письма с вложением файла:

Процедура ОтправитьПочтуШтатно2()

    ИмяПриложения =“windowstmail.exe”;

    Аргументы =“-totest@test.ru-subject“”Проверка отправки почты2″” -body “”текст письма:проверка отправки почты”” -attach “”file1.txt“” “;

    СтрокаКоманды = ИмяПриложения +” “+ Аргументы;

    ЗапуститьПриложение(СтрокаКоманды,“windows”,Ложь);

КонецПроцедуры

Создано новое письмо с вложением:

 PocketOutlook2

Такой же результат можно получить, используя соответствующий метод внешней компоненты «ExtService», актуально, если ваша версия 1С ниже 8.1.4.4.

ExtService, вариант 1:

Процедура ExtEmail()

    ИмяПриложения   =“windowstmail.exe”;

    Аргументы       =“mailto:test@test.ru?subject=Проверка отправки почты&body=текст письма:проверка отправки почты”;

    ВК.ИспользоватьФункцииОболочки(Истина);

    ВК.ЗапуститьПриложение(ИмяПриложения,Аргументы,Ложь);

    ВК.ИспользоватьФункцииОболочки(Ложь);

КонецПроцедуры

ExtService, вариант 2:

Процедура ExtEmail2()

    ИмяПриложения   =“windowstmail.exe”;

    Аргументы       =“-to”"test@test.ru”"-subject”"Проверка отправки почты2″”-body”"текст письма:проверка отправки почты”"-attach “”file1.txt”" “;

    ВК.ИспользоватьФункцииОболочки(Истина);

    ВК.ЗапуститьПриложение(ИмяПриложения,Аргументы,Ложь);

    ВК.ИспользоватьФункцииОболочки(Ложь);

КонецПроцедуры

Процедура загрузки внешней компоненты в данном примере не показана, более подробно описание доступных методов смотрите в разделе «Документация».

В данном примере использовались:

Марка, модель КПК

Версия  ОС

Версия 1С

Версия ExtService

Symbol MC 7004

WM 5

8.1.6.21

1.0.1.61

(коммуникатор без GPS)


Похожие записи: